W dniu dzisiejszym Sebastian Bergmann poinformował na swoim blogu o wydaniu najnowszej wersji PHPUnit. Nowe wydanie zostało oznaczone numerkiem 3.7.0.

Jako kluczowe zmiany zostały wymienione między innymi:

  • zastosowanie nowych asercji – dla przykładu operujących na danych JSON
  • modyfikacja wyglądu raportów pokrycia kodu
  • przywrócenie możliwości uzyskania generycznego wyjątku (typu Exception) w notacji @expectedException

Nowa wersja PHPUnit wymaga stosowania PHP w wersji co najmniej 5.3.3 lub 5.4.7. Natomiast PHP_CodeCoverage współpracuje nadal z Xdebug w wersji 2.0.5, jednak zalecana jest aktualizacji do wersji 2.1.1.

Nowa wersja PHPUnit
Tagged on:                         

Leave a Reply

Your email address will not be published. Required fields are marked *

Social Widgets powered by AB-WebLog.com.